Forums not loading
Incident Report for Topcoder
Resolved
The incident has been resolved. Forums are working fine now.
Posted Aug 21, 2020 - 01:29 EDT
Investigating
We are currently investigating the incident
Posted Aug 21, 2020 - 00:54 EDT
This incident affected: Forums.