Challenge App and Direct App are down
Incident Report for topcoder
Resolved
All systems have been fixed. Sorry for the inconvience
Posted 7 months ago. Mar 25, 2018 - 08:37 EDT
Update
Login functionality is not working
Posted 7 months ago. Mar 25, 2018 - 08:05 EDT
Investigating
We are currently investigating this issue.
Posted 7 months ago. Mar 25, 2018 - 07:21 EDT